Aussentemperatur und Luftfeuchtigkeit in Systemvariable schreiben funktioniert nicht | Umwelt | Forum | ELV Elektronik
Shop-Wechsel

Der Warenkorb wird nicht übernommen.

Zum Firmenkunden / Bildungseinrichtungs Shop

Umwelt

Aussentemperatur und Luftfeuchtigkeit in Systemvariable schreiben funktioniert nicht

Beiträge zu diesem Thema: 13
Aussentemperatur und Luftfeuchtigkeit in Systemvariable schreiben funktioniert nicht
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
24.03.2016, 10:36
Hallo,

ich möchte die Aussentemperatur und Luftfeuchtigkeit meines Sensors (HM-WDS10-TH-O) zyklisch ermitteln und in Systemvariablen schreiben.

Dabei habe ich den ELV-Tipp umgesetzt und angepasst: "ELV-FAQ zu: Script: Vergleich von Innen- und Außen-Temperatur und Luftfeuchte und setzen von Systemvariablen"

Meine Systemvariablen sind:
Aussentemperatur, Zahl, Maßeinheit °C, ohne Kanal
Aussenluftfeuchtigkeit, zahl Maßeiniheit %, ohne Kanal

Mein Zentralenprogramm sieht wie folgt aus:
Wenn
Geräteauswahl MeinSensor bei Temperatur im Wertebereich "von 0.00° C bis kleiner 0.00° C" bei Änderung auslösen
Dann
Script
var dp_temperatur_aussen = dom.GetObject("BidCos-RF.SNmeinesSensors:1.TEMPERATURE");
var Aussentemperatur = dp_temperatur_aussen.State();
var dp_feuchte_aussen = dom.GetObject("BidCos-RF.SNmeinesSensors:1.HUMIDITY");
var Aussenluftfeuchtigkeit = dp_feuchte_aussen.State();

Meine beiden Systemvariablen lasse ich mir auf der Startseite anzeigen. Leider zeigen mir die Variablen immer den Wert 0 an, obwohl sich die Temperatur des Sensors verändert hat.

Im angegebenen ELV-Tipp war nichts von ...im Wertebereich "von 0.00° C bis kleiner 0.00° C" zu sehen, obwohl ich das angeben muss.

Der ELV-Tipp zeigte nur:

Bedinung: Wenn...
Geräteauswahl - Temperatur-/Feuchtesensor Außen - auslösen auf Aktualisierung
Aktivit: Dann...
Skript - Skript erstellen

Hat jemand eine Idee, waran es liegen kann, dass die Variablen nicht geschrieben werden?

Gruß
Thomas
Aw: Aussentemperatur und Luftfeuchtigkeit in Systemvariable schreiben funktioniert nicht
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
24.03.2016, 11:05
Hallo singer245,

der von ihnen beschriebene Fehler habe ich auch festgestellt und ELV - bereits vor Monaten - mitgeteilt:

*ELV-Ticket: E895189566ECD
* eQ-3 - Ticket: EQ3_SUPPORT-257

Leider habe ich in dieser Richtung nie mehr was von ELV gehört.
Dieses Phänomen ist auch nach 3 "CCU2-update" immer noch nicht behoben.

Ich konnte feststellen, wenn ich die Systemvariable der Startseite zugefügt hatte, konnte ich die Systemvariabel (Wert und Zeitpunkt) darstellen. Einstellunngen --> Benutzerverwaltung --> Bearbeiten --> Systemvariable hinzufügen.

Probieren Sie doch einmal auch diesen Weg, damit konnte ich mir helfen.

Gruß

--> So wie ich sehe frage Sie den Kanal 1 ab. Sehen Sie im Gerätemenü einmal nach, ob auch die checkbox "Sende Temperatur- und Feuchtigkeitswert" gesetzt ist? Unabhängig von den bekannten Fehlern kann ich z.B. manuell mit Tastendruck die Programmtriggerung (script ähnlich) starten und den Wert der Isttemperatur auslesen, anzeigen oder einem anderen Thermostat zuweisen. Z.B. Istwert von "A" einlesen und als neuen Sollwert an den Thermostat "B" weiterleiten. Geht und wird auch dort angezeigt.


Viele Grüße..elkotek
Aw: Aussentemperatur und Luftfeuchtigkeit in Systemvariable schreiben funktioniert nicht
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
24.03.2016, 15:35
Hallo elkotek,

danke für die Info.

Also im Gerätemenü des Sensors sehe ich keien Checkbox "Sende Temperatur- und Feuchtigkeitswert". Nur die Checkbox 'Wake-On-Radio' kann ich selektieren. Ich kann also nichts weiteres einstellen.

In der Übersichtsseite aller Geräte ist nur die ertse Checkbox (sichtbar) aktiv. Die beiden anderen Checkboxen (bedienbar und protokolliert) nicht aktiv.

Gruß
Thomas
Aw: Aussentemperatur und Luftfeuchtigkeit in Systemvariable schreiben funktioniert nicht
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
24.03.2016, 18:49
Hallo Thomas,

sorry ich war einfach zu schnell und dachte es geht um den HM-TC-IT-WM-W-EU, da gibt es diese 2 Kanäle.

Wenn die checkbox vom Sensor auf sichtbar und protokollieren gesetzt ist, bitte nachprüfen ...ob zyklisch die entsprechenden Werte im Systemprotokoll aufgeführt werden.

Wenn ja testen Sie einmal folgendes script für den eingesetzten Sensor.

1. Systemvariable vom Typ Zahl erstellen -->Name--> Wertauslesen
2. Die Systemvariable auf sichtbar und protokollieren setzen. Für den Test diese Systemvariable gleich der Startseite zuordnen
3. Programm für das script erstellen ..zur Triggerung z.B. einmal einen manuellen Taster verwenden, damit man selbst bestimmen kann, wann die Triggerung erfolgen soll.

Wenn... - Taste - kurz gedrückt
Dann....script
var Sensor = dom.GetObject("BidCos-RF.XXXXXXXXXX:1.TEMPERATURE");
var Wertauslesen = dom.GetObject ("Wertauslesen");
Wertauslesen.Variable (Sensor.Value() );

wo: XXXXXXXXXX der RF-Code des Sensors ist. Nach Eingabe vom script gleich Fehlerprüfung durchführen und mit ok..abschließen.

Viele Grüße

Viele Grüße..elkotek
Aw: Aussentemperatur und Luftfeuchtigkeit in Systemvariable schreiben funktioniert nicht
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
25.03.2016, 14:27
Hallo elkotek,

der letzte Tipp war korrekt. Nachdem ich eine manuelle Auslösung des Triggers auf meinen Handsender gelegt und manuell ausgelöst habe, wurde auch die korrekte Temperatur in die Variable geschrieben.

Entsprechend habe ich das mit der Luftfeuchtigkeit gemacht und das wird ebenfalls jetzt in der Variabele Aussenluftfeuchtigkeit angezeigt.

Eine kleine Nachfrage habe ich noch (der Optik wegen):
Angezeigt werden die Werte auf der Startseite wie folgt:
Aussentemperatur: 8.300000
Aussenluftfeuchtigkeit: 87.000000

Obwohl ich die Maßeinheiten in den Variablen eingestellt habe (°C und %) werden deise nicht auf der Startseite angezeigt. Warum ist das so?

Vielen Dank für deine Hilfe
Gruß
Thomas
Aw: Aussentemperatur und Luftfeuchtigkeit in Systemvariable schreiben funktioniert nicht
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
25.03.2016, 19:42
Hallo Thomas,

freut mich, dass die Sache geklappt hat. Probieren Sie folgendes einmal aus...um das Format der Anzeige zu ändern.

Ergänzen Sie das script um eine weitere Zeile:
var Sensor = dom.GetObject("BidCos-RF.XXXXXXXXXX:1.TEMPERATURE");
var Wertauslesen = dom.GetObject ("Wertauslesen");
Wertauslesen.Variable (Sensor.Value());
SystemvariableTestzahl.Variable(Wertauslesen.Value().ToString(2));

wo: Testzahl eine neue Systemvariable vom Typ Zeichenkette ist und die Zahl (2) die Anzahl der Nachkommastellen. Das C kriege ich auch nicht hin.

Viele Grüße
Viele Grüße..elkotek
Aw: Aussentemperatur und Luftfeuchtigkeit in Systemvariable schreiben funktioniert nicht
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
29.07.2019, 08:26
Hallo,
habe das ganze auch versucht, mit den Homematic Komponenten bekomme ich das auch hin, jetz habe ich aber einen IP temperatursensor und es klappt nicht, habe folgenses script verwendet:

var Sensor = dom.GetObject("HmIP-RF.000EDA498FD375:1.TEMPERATURE");
var Wertauslesen = dom.GetObject ("Wertauslesen");
Wertauslesen.Variable (Sensor.Value() );

wo ist der Fehler?
Aw: Aussentemperatur und Luftfeuchtigkeit in Systemvariable schreiben funktioniert nicht
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
29.07.2019, 08:31
Hallo Black 8,

um welche Gerätetytpe handelt es sich ???
Viele Grüße..elkotek
Aw: Aussentemperatur und Luftfeuchtigkeit in Systemvariable schreiben funktioniert nicht
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
29.07.2019, 08:55
Probiere im Testfenster der Scripts zu prüfen, ob die Werte belegt sind

var Sensor = dom.GetObject("HmIP-RF.000EDA498FD375:1.TEMPERATURE");
WriteLine(Sensor);
var Wertauslesen = dom.GetObject ("Wertauslesen");
WriteLine(Wertauslesen);
Wertauslesen.Variable (Sensor.Value() );


Probiere
Wertauslesen.State(Sensor.Value());



Christian
Aw: Aussentemperatur und Luftfeuchtigkeit in Systemvariable schreiben funktioniert nicht
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
29.07.2019, 09:07
nur zur Information.

...es nützt gar nichts, wenn man nicht weis um welche Type es sich handelt. Man muss schon den Datenpunkt und die Werteabfrage genau definieren.
Zum Beispiel für den HmIP-WTH-2 oder HmIP-STHO hier muss man exakt schreiben:

statt TEMPERATURE ---> ACTUAL_TEMPERATURE

Also für die Temperatur:

var temp = dom.GetObject("HmIP-RF.000EDA498FD375:1.ACTUAL_TEMPERATURE").Value();
WriteLine(temp);

Für die Feuchte:
var rF = dom.GetObject("HmIP-RF.000EDA498FD375:1.HUMIDITY").Value();
WriteLine(rF);

Viele Grüße..elkotek
Aw: Aussentemperatur und Luftfeuchtigkeit in Systemvariable schreiben funktioniert nicht
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
29.07.2019, 19:20
Hallo es ist ein HmIP-STHO
werde morgen die Vorschläge testen,
danke schon mal
Aw: Aussentemperatur und Luftfeuchtigkeit in Systemvariable schreiben funktioniert nicht
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
29.07.2019, 19:26
Hallo,
das ACTUAL hat geholfen, danke
Aw: Aussentemperatur und Luftfeuchtigkeit in Systemvariable schreiben funktioniert nicht
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
29.07.2021, 12:29
Hallo Freunde,

ich dachte könnte mal schnell Gartenbewässerung, Alarmanlage usw. mit Homematic Komponenten realisieren - bin ja Rentner mit elektronischen Kenntnissen aber ohne große Geduld mich in die Scriptsprache einzuarbeiten, da mein Studium mit ein paar Semestern der Programmierung von Lochstreifen angetriebenen Computern schon 46 Jahre zurück liegt.

Soweit zur Vorstellung.

Mich interessiert hier aber das Auslesen der Daten des HmIP Temperatur Aussensensors, um es zur Anzeige auf einen HMIP Innensensor zur bringen. Müsste doch mit einem Script möglich sein?

Ich würde auch einen kleinen Obulus springen lassen :)

Will dieses Projekt auch gleich nutzen, um mich ein wenig mit dieser Art der Programmierung vertraut zu machen.

Meine Komponenten laufen alle in Verbindung mit der CCU3 und sind nicht nur HmIP fähig.

Hab auch ein wenig gebastelt und mir zur Ansteuerung meiner Gardena Magnetventile den Bastelsatz 4-Fach Schaltaktor HM-LC-Sw4-PCB 3x zugelegt.



Wäre sehr dankbar für etwas Hilfe.

Gruss

Jonvelle