Shop-Wechsel

Der Warenkorb wird nicht übernommen.

Zum Firmenkunden / Bildungseinrichtungs Shop

Wetter-Datenlogger

USB-WDE1 am Rapsberry Pi

Beiträge zu diesem Thema: 3

ELV USB-Wetterdaten-Empfänger USB-WDE1

Artikel-Nr.: 092030

zum Produkt
USB-WDE1 am Rapsberry Pi
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
18.08.2012, 21:44
Hallo,

ich möchte gerne einen USB-WDE1 an einem Raspberyy Pi betreiben. Der Raspi läuft unter Raspbian “wheezy” vom

15.07.2012. Leider lässt sich die baud-rate der seriellen Schnittstelle nicht konfigurieren, siehe die folgenden

Kommandos direkt nach dem anschliessen des WDE1 und nach dem stty Kommando.



pi@kermit ~ $ stty -F /dev/ttyUSB1 -a
speed 0 baud; rows 0; columns 0; line = 0;
intr = ^C; quit = ^\; erase = ^?; kill = ^U; eof = ^D; eol = <undef>; eol2 = <undef>; swtch = <undef>;
start = ^Q; stop = ^S; susp = ^Z; rprnt = ^R; werase = ^W; lnext = ^V; flush = ^O; min = 1; time = 0;
-parenb -parodd cs8 hupcl -cstopb cread clocal -crtscts
-ignbrk -brkint -ignpar -parmrk -inpck -istrip -inlcr -igncr icrnl ixon -ixoff -iuclc -ixany -imaxbel -iutf8
opost -olcuc -ocrnl onlcr -onocr -onlret -ofill -ofdel nl0 cr0 tab0 bs0 vt0 ff0
isig icanon iexten echo echoe echok -echonl -noflsh -xcase -tostop -echoprt echoctl echoke


pi@kermit ~ $ stty -F /dev/ttyUSB1 speed 9600
0


pi@kermit ~ $ stty -F /dev/ttyUSB1 -a
speed 0 baud; rows 0; columns 0; line = 0;
intr = ^C; quit = ^\; erase = ^?; kill = ^U; eof = ^D; eol = <undef>; eol2 = <undef>; swtch = <undef>;
start = ^Q; stop = ^S; susp = ^Z; rprnt = ^R; werase = ^W; lnext = ^V; flush = ^O; min = 1; time = 0;
-parenb -parodd cs8 hupcl -cstopb cread clocal -crtscts
-ignbrk -brkint -ignpar -parmrk -inpck -istrip -inlcr -igncr icrnl ixon -ixoff -iuclc -ixany -imaxbel -iutf8
opost -olcuc -ocrnl onlcr -onocr -onlret -ofill -ofdel nl0 cr0 tab0 bs0 vt0 ff0
isig icanon iexten echo echoe echok -echonl -noflsh -xcase -tostop -echoprt echoctl echoke



dmesg sieht wie folgt aus:

 usb 1-1.3.3: new full speed USB device number 8 using dwc_otg
usb 1-1.3.3: New USB device found, idVendor=10c4, idProduct=ea60
usb 1-1.3.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 1-1.3.3: Product: ELV USB-WDE1 Wetterdatenempf\xffffffc3\xffffffa4\xffffffa4nger
usb 1-1.3.3: Manufacturer: Silicon Labs
usb 1-1.3.3: SerialNumber: TAMN6RA8WL1PHAAE
cp210x 1-1.3.3:1.0: cp210x converter detected
usb 1-1.3.3: reset full speed USB device number 8 using dwc_otg
usb 1-1.3.3: cp210x converter now attached to ttyUSB1


Wo könnte die Ursache liegen?
Wie kann man sie beheben?
Hat schon jemand den USB-WDE1 mit dem Raspi erfolgreich verbunden?

Gruß
Stefan
Aw: USB-WDE1 am Rapsberry Pi
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
31.01.2013, 10:58
hallo,

der usb-wde1 geht mit deiner konfiguration eigentlich out of the box.
probier mal:
socat /dev/ttyUSB0,b9600 STDOUT

die ausgabe sieht dann in etwa so aus:
$1;1;;13,8;22,7;22,6;17,8;22,1;21,2;22,9;;59;35;38;49;38;40;35;;;;;;;0
$1;1;;13,8;22,7;22,6;17,8;22,1;21,2;22,9;;59;35;38;49;38;40;35;;;;;;;0

hier findest du auch eine kleine praktische anwendung, läuft prima bei mir.
http://cweiske.de/tagebuch/wetterdaten-usb-wde1.htm

Aw: USB-WDE1 am Rapsberry Pi
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
31.01.2013, 19:59
Hallo,

seit einem apt-get update und upgrade irgendwann im September '12 funktioniert es auch bei mir. Da gab es irgendeinen Bug in der seriellen Kommunikation des Raspbian.