Shop-Wechsel

Der Warenkorb wird nicht übernommen.

Zum Firmenkunden / Bildungseinrichtungs Shop

Uhren

Unterschiedliche Probleme mit dem Modul

Liebe ELVforum-Community, mit dem heutigen Tag informieren wir Sie darüber, dass dieses Forum demnächst eingestellt wird. Alle weiteren Informationen zu diesem Schritt und welche Alternative wir planen, entnehmen Sie bitte dem angepinnten Forumsbeitrag.
Beiträge zu diesem Thema: 25
1 von 2

ELV Bausatz Real-Time-Clock-DCF-Modul mit I2C, SPI u. UART-Schnittstelle, RTC-DCF

Artikel-Nr.: 130541

zum Produkt
Unterschiedliche Probleme mit dem Modul
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
27.07.2014, 11:43
Ich verwende das Modul als Uhr in einem Weckerprojekt. Nun ist es leider so, dass ich mit verschiedenen Problemen kämpfe, die ziemlich ärgerlich sind:

- Der minütliche Interrupt, den ich eigentlich für die Aktualisierung der Uhrzeit in meinem Mikrocontroller nutzen wollte, funktioniert nicht. Nach dem Anschalten der Stromversorgung für das Modul kommt dieser Interrupt 1-2 mal, danach wird er einfach nicht mehr ausgelöst.

- Der sekündliche Interrupt (Levelmodus) funktioniert zwar, aber es werden gelegentlich Ticks ausgelassen. Mir scheint es so, dass besonders bei Sekunde 0 sehr oft kein Interrupt kommt, aber auch andere von mir probierte Werte fallen alle paar Minuten mal weg.

- Nach langer Laufzeit (mehrere Tage, teilweise Wochen) hängt sich der DCF-Decoder scheinbar auf. Der DCF-Interrupt wird dann nicht mehr ausgelöst und die Uhrzeit nicht mehr aktualisiert, obwohl das Modul an einem Ort steht, an dem davor zuverlässig jede Minute ein DCF-Signal empfangen wurde. Das Modul muss dann stromlos gemacht werden, damit sich der Empfänger wieder einnordet, anschließend funktioniert es wieder ein paar Tage lang. Das ist in meinem Aufbau etwas unpraktisch, da ich vor dem Spannungswandler für das DCF-Modul einen 1,5F-Kondensator verbaut habe, der der Uhr eine Laufreserve von ca. 3 Minuten gibt ... Wenn DCF mal wieder hakt, muss ich den Wecker also immer 3-4 Minuten vom Netz trennen, bevor es wieder geht.

Ich habe auf dem Modul die aktuellste Firmwareversion (1.1).

Ich weiß nun nicht, ob mein Modul vielleicht irgendwie defekt ist oder ob die Hardware einfach Designfehler hat - ich will deshalb auf keinen Fall Schuldzuweisungen formulieren. Es ist halt nur ziemlich schade, dass ich mein Projekt so nicht in Betrieb nehmen kann, weil ein Wecker, der nicht zuverlässig weckt, ja doch eher sinnfrei ist.
Aw: Unterschiedliche Probleme mit dem Modul
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
13.08.2014, 09:19
Hallo DerZappes,

bislang haben uns noch keine ähnlichen Kundenrückmeldungen zum Real-Time-Clock-DCF-Modul erreicht. Da wir einen Hardwaredefekt nicht ausschließen können, empfehlen wir Ihnen sich mit unserem Kundenservice ( kundenservice@elv.de ) in Verbindung zu setzen, um ein neues Modul zu erhalten.

Mit freundlichen Grüßen euer Team der technischen Kundenbetreuung
Aw: Unterschiedliche Probleme mit dem Modul
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
13.08.2014, 09:37
Hallo Herr Sandhorst,

ich werde den Kollegen gleich eine Mail schreiben. Bis dahin noch ein kleines Update zur Fehlermeldung:

Ich habe, wie es in einem anderen Thread hier empfohlen wurde, die Firmware des Moduls noch einmal neu geflasht. Daraufhin hat der DCF-Empfang etwa eine Woche lang funktioniert, bis ich wieder einen einzelnen Aussetzer hatte.

Nun ist es so, dass ich in meinem Code eine Sache zur Vereinfachung des Programmflusses mache, die vielleicht ein Problem sein könnte. Immer, wenn der DCF-Interrupt aufgetreten ist, beschreibe ich nach dem Löschen des Interrupt-Flags das DCF-Kontrollregister neu mit dem Wert 3, so dass der DCF-Empfang an sich und der Interrupt enabled werden. Nötig ist das kaum, aber es entwirrt den Kontrollfluss in meinem Code an dieser Stelle.

Halten Sie es für denkbar, dass hier gelegentlich sowas passiert wie ein Schreibzugriff auf die Kontrollregister zu einem Zeitpunkt, zu dem gerade irgendwas anderes im Mikrocontroller abläuft, was wiederum zu einem "Schluckauf" der Modulfirmware führt? Ohne Sourcecode der Firmware kann ich das selbst natürlich nicht überprüfen, aber der Fehler sieht für mich fast nach so etwas in der Art aus.
Aw: Unterschiedliche Probleme mit dem Modul
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
13.08.2014, 10:33
Hallo DerZappes,

denkbar wäre dieses Verhalten. Sie sollten Ihre Programmierung dahingehend ggf. abändern. Eine individuelle Programmanalyse können wir im Rahmen der kostenlosen technischen Kundenberatung jedoch nicht anbieten.

Mit freundlichen Grüßen euer Team der technischen Kundenbetreuung
Aw: Unterschiedliche Probleme mit dem Modul
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
13.08.2014, 11:08
Hallo Herr Sandhorst,

mir ist schon klar, dass Sie bei so einem kleinen Bausatz nicht gleich zum Debugger greifen können. :) Ich wollte die Beobachtung nur in den Raum stellen, falls jemals ein Trouble-Ticket für die Techniker draus wird. Die freuen sich ja immer über Hinweise auf die Ursache von Fehlverhalten.

Vielen Dank für die Hilfe, ich habe das mit dem Kundendienst sehr befriedigend geregelt!
Aw: Unterschiedliche Probleme mit dem Modul
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
07.12.2014, 11:26
Ich hatte im August ein neues Modul vom Kundendienst bekommen, da man davon ausging, dass meines defekt sein muss. Ich habe dieses Austauschmodul in meiner Schaltung verbaut und stelle dort exakt die gleichen Probleme fest, wie ich sie mit dem Originalteil hatte.

Nach längerer Laufzeit (mehrere Wochen) bleiben zunehmend Interrupts aus, die Funksynchronisation klappt nicht mehr und früher oder später bleibt meine Uhr, die sich auf die Interrupts des Moduls verlässt, einfach stehen. Ich verscuhe derzeit, einen Firmware-Workaround zu finden, nachdem ich bereits einmal zu spät ins Büro gekommen bin, aber auf Dauer werde ich mir wohl ein eigenes Uhrenmodul bauen müssen, da das ELV-Modul einfach nicht zuverlässig genug für einen Wecker ist. Das ist wirklich schade, da ich das Modul vom Konzept und der Anwendung her eigentlich toll finde - aber das hilft ja nicht wirklich etwas, wenn es schlicht nicht funktioniert.
Aw: Unterschiedliche Probleme mit dem Modul
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
09.02.2015, 21:43
Hallo,

ich kann die Probleme mit der RTC+DCF-Modul bestätigen. Ich entwickle im Rahmen des Studiums gerade eine Funkuhr, die das Modul verwendet.

Ich kommuniziere über UART bei 4800 Baud mit dem Modul. Außerdem lasse ich mir einen 1Hz Sekundeninterrupt schicken. Bei der Initialisierung beschreibe ich also das
Interrupt-Register 0x2a mit 0x00,
Interruptconfig-Register 0x2c mit 0x02 (Maskiert 0x10 0x82)

und für den DCF-Empfang das
DCFconfig-Register 0x2d mit (0x01 | 0x02 | 0x04)

Nun bekomme ich den Sekundentakt und frage 1 mal pro Min. das
Status-Register 0x2e ab, ob ein Signal empfangen wurde. Wenn ja, frage ich die Zeit ab.

Das funktioniert soweit erstmal, allerdings ergeben sich im Dauerbetrieb 2 Probleme.

1. Die RTC führt anscheinend keinerlei Plausibilitätskontrolle der Uhrzeit durch. Mal bekommt man eine korrekte Uhrzeit, mal etwas mit 85:12. Das ist insofern ärgerlich, als dass z. B. die Weckfunktion der RTC somit hinfällig wird, weil nicht mehr zuverlässig. Außerdem ist man gezwungen, nun selbst noch für Plausibilitätskontrollen zu sorgen. Das ist schon etwas aufwändig, wenn es zuverlässig sein soll.

2. In unregelmäßigen Abständen, mal Tage lang nicht, dann wieder jede Std. wird kein Sekundeninterrupt mehr gesendet. Hierbei ist mir die Besonderheit aufgefallen, dass der Interrupt wieder einsetzt, wenn ich nach ein paar Sekunden das Uhrzeitregister abfrage. Ich glaube, hin und wieder war es auch nötig, die Config-Register neu zu beschreiben. Bin mir hier aber nicht sicher, da es auch an der Wartezeit gelegen haben könnte. Jedenfalls hilft dieses "Anschubsen" immer nur für <1Min.. Unterbricht man kurzzeitig die Stromversorgung des Moduls und startet es neu, läuft der Interrupt meistens wieder etwas länger, bleibt teilweise vorerst garnicht mehr stehen.

Ich habe zwei dieser Module hier zu Hause und beide verhalten sich identisch. Einen Defekt halte ich somit für eher unwahrscheinlich.

Ich hoffe doch sehr, dass sich da bei ELV nochmal jemand an die Arbeit macht. Denn zuverlässige Funkuhren lassen sich so nicht bauen. Genau dafür habe ich das Modul allerdings gekauft.
Aw: Unterschiedliche Probleme mit dem Modul
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
20.02.2015, 10:33
Hallo HannesJo,

im Entwicklungsbereich konnte das von Ihnen festgestellte Verhalten nachvollzogen werden. Die Firmware wird daher entsprechend überarbeitet werden. Sobald das Update verfügbar ist, können Sie das Firmwareupdate unter dem folgenden Weblink herunterladen:

http://www.elv.de/real-time-clock-dcf-modul-mit-i2c-spi-u-uart-schnittstelle-rtc-dcf-bausatz.html

Sie können sich über den ELV-Agenten über die Verfügbarkeit des Updates informieren lassen. Klicken Sie hierzu bitte auf das Optionsfeld "Artikel mit ELV-Agent merken/beobachten". In dem darauf sich öffnenden Fenster können Sie auswählen, dass Sie eine Benachrichtigung erhalten, wenn neue Downloads verfügbar sind.

Für Ihren wichtigen Hinweis möchten wir uns abschließend nochmals bei Ihnen bedanken.
Mit freundlichen Grüßen euer Team der technischen Kundenbetreuung
Aw: Unterschiedliche Probleme mit dem Modul
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
07.04.2015, 13:50
Hallo,

wann gibt es das Firmware-Update - es nervt schon einmal am tag das modul neu starten zu müssen!
Aw: Unterschiedliche Probleme mit dem Modul
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
15.04.2015, 16:06
Hallo tom.stemmler,

das Firmware-Update ist doch schon direkt beim Artikel hinterlegt?!

Mit freundlichen Grüßen euer Team der technischen Kundenbetreuung
Aw: Unterschiedliche Probleme mit dem Modul
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
18.05.2015, 14:51
Hallo Herr Sandhorst,

das angekündigte Firmwareupdate ist entgegen Ihrer Angabe nicht hinterlegt. Passiert hier noch was?

In dem aktuellen Zustand (Firmware 1.1) ist das Modul für den Dauereinsatz nicht zu gebrauchen, wie schon mehrfach von unterschiedlichen Käufern mit verschiedenen Problemen berichtet wurde. 12 € mag nicht viel Geld und auch der Grund sein, warum es nicht viele Kundenbeschwerden gibt. Aber die Arbeit und die Unzufriedenheit, die einem ein unreifes Produkt beschert, ist wesentlich unangenehmer als ein paar fehlinverstierte Euro...
:(

Die Beiträge von ELV in diesem Forum beschränken sich auf Beschwichtigungen und Umtausch wegen Defekt? Sorry, aber wenn das Ding nicht richtig funktioniert, dann verkauft es halt nicht. Da hätten alle mehr von.

Gruß
R.Perkuhn

Aw: Unterschiedliche Probleme mit dem Modul
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
22.05.2015, 12:15
Hallo robatp

Das Update beinhaltet den Firmwarestand 1.1. Welche Funktionen sind denn in Ihrem Fall nicht gegeben?
Mit freundlichen Grüßen euer Team der technischen Kundenbetreuung
Aw: Unterschiedliche Probleme mit dem Modul
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
22.05.2015, 12:29
Hallo Herr Müller,

nicht gegeben ist die Funktion der zuverlässigen Funktion des Moduls. Detaillierte Beschreibungen finden sich in mehreren Postings dieses Forenthreads.

Ich habe inzwischen eine Warnleuchte in meinen Wecker gebaut, die blinkt, wenn die Synchronisation stirbt, damit ich flcuhend den Stecker rausziehen und wieder reinstecken kann.
Aw: Unterschiedliche Probleme mit dem Modul
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
26.05.2015, 08:47
Hallo Herr Müller,

mit einem Blick auf das Datum der Firmware 1.1 (aus dem Jahr 2013) lässt sich leicht erkennen, dass die hier beschriebenen (und angeblich vom Entwicklungsbereich nachvollzogenen) Probleme aus dem Jahr 2015 sicher nicht behoben wurden.

Wenn man ganz sicher sein möchte, kann man noch die Release Notes ansehen, dort sind gänzlich andere Fehler beschrieben und behoben worden als die Probleme aus diesem Thread.

Falls Sie es noch nicht getan haben, so lesen Sie doch einfach die sehr informativen Postings von DerZappes und HannesJo und sprechen Sie Ihren Kollegen Herr Sandhorst darauf an. Der war nach eigenen Angaben ja schon weiter mit der Problembehebung.

Gruß
R.Perkuhn

Aw: Unterschiedliche Probleme mit dem Modul
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
03.06.2015, 23:38
beim Artikel liegt immernoch die alte firmware...
Aw: Unterschiedliche Probleme mit dem Modul
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
11.06.2015, 14:40
Hallo zusammen,

vielen Dank für Ihre Rückmeldungen. Wir haben die noch offenen Punkte gesammelt und an die eQ-3 Entwicklungsabteilung weitergeleitet. Dort soll das Verhalten weiter untersucht werden. Aufgrund der hohen Auslastung wird die Bearbeitung jedoch voraussichtlich erst im Juli erfolgen können. Alternativ bieten wir Ihnen die Rücknahme der Module zur Gutschrift an. Sobald es Neuigkeiten zu diesem Thema gibt, werden wir uns wieder melden. Vielen Dank für Ihr Verständnis.

Mit freundlichen Grüßen euer Team der technischen Kundenbetreuung
Aw: Unterschiedliche Probleme mit dem Modul
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
12.06.2015, 08:37
ja, die hoffnung stirbt zuletzt...
Aw: Unterschiedliche Probleme mit dem Modul
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
22.09.2015, 16:47
Nun habe ich die neue Firmware vor ein paar Tagen aufgespielt, das ging ohne Probleme, danach lief die Uhr auch wieder normal (mit den üblichen 10 zusätzlichen Sekunden pro halben Tag, wenn sie kein richtiges Zeitsignal empfangen konnte).
Zumindest zeigte sie nie mehr wieder seltsame Anzeigen (89:25:13....) bis...
...und jetzt kommt das ABER...
seit 2 Tagen mag sie plötzlich keine Uhrzeit mehr empfangen - es wurde NICHTS geändert, weder der Standort noch die Umgebung.
Mehrfaches Neustarten half nichts, der RTC lässt normal sich setzen und auslesen, aber DCF scheint nicht mehr zu funktionieren.
Gruß
Aw: Unterschiedliche Probleme mit dem Modul
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
22.09.2015, 19:58
Hallo tom.stemmler,
seit 2 Tagen mag sie plötzlich keine Uhrzeit mehr empfangen - es wurde NICHTS geändert, weder der Standort noch die Umgebung.
Mehrfaches Neustarten half nichts, der RTC lässt normal sich setzen und auslesen, aber DCF scheint nicht mehr zu funktionieren.

Bitte nochmal in der Umgebung prüfen, ob sich nicht doch etwas geändert hat. Zum Beispiel durch den Gebrauch von modernen Netzteilen mit Schaltreglertechnik.
Es stellt sich immer häufiger heraus, das diese Netzteile oft im Frequenzbereich des zu empfangenen DCF-Signals Störungen erzeugen und somit den DCF-Empfänger "blockieren".

Ein Test an einem anderen Standort, am besten natürlich im Freien, könnte jedenfalls zunächst klären, ob das Modul noch funktioniert.

Gruß Sheldon
Ich bin nicht verrückt… Meine Mutter hat mich testen lassen. (Sheldon Cooper)
Aw: Unterschiedliche Probleme mit dem Modul
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
23.09.2015, 23:12
alles geprüft, alles einwandfrei,

Ich habe soeben auch mit einem Oszi die Pulse, die aus dem DCF-Teil rauskommen gemessen, die sind ganz sauber und wenn ich mitschreibe, stimmt das Zeitsignal auch in jeder Minute, also keine Fehler, die ein korrektes Zeiteinlesen verhindern würden.
aus dem RTC kommt aber immer nur noch die RTC-Zeit (zählt also einfach von 0:00:00 los... und stellt sich nicht nach DCF)

Um 100% sicher zu sein, habe ich das dcf77interrupt Ardunio-Script anstelle meines eigenen Uhrenscripts geladen, es geht einfach nicht. und wie schon geschrieben - einfach nach ein paar Tagen normalem Betrieb ist das nun so.

Gruß
Aw: Unterschiedliche Probleme mit dem Modul
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
26.09.2015, 10:32
nochmal ich...

ich habe nun die alte FW aufgespielt (1.1) damit funktionierts wieder wie vorher....
(leider ohne Zeitfehlererkennung)
das ist aber nicht die Lösung

Gruß
Aw: Unterschiedliche Probleme mit dem Modul
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
12.10.2015, 08:41
Hallo zusammen,

es wird in Kürze ein weiteres Firmware-Update für das Modul geben. Sie können den ELV-Agenten beim Artikel im Webshop verwenden, um sich über neue Downloads per eMail informieren zu lassen.


Mit freundlichen Grüßen euer Team der technischen Kundenbetreuung
Aw: Unterschiedliche Probleme mit dem Modul
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
12.10.2015, 09:27
sehr schön, bin gespannt, ach.. benennt doch am besten die Datei (auch schon auf der Seite beim Produkt) nicht einfach "Software", sondern mit der Versionsnummer, damit mans gleich sieht.
Danke
Aw: Unterschiedliche Probleme mit dem Modul
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
16.10.2015, 08:12
Hallo zusammen,

die Firmware in Version 1.3 sollte in der kommenden Woche zum Download bereitgestellt werden.

Mit freundlichen Grüßen euer Team der technischen Kundenbetreuung
1 von 2