Funk-System Homematic

Stromversorgungsproblem: RPI-RF-MOD mit Raspberry Pi 4 (Stacking Header) und SSD-Festplatte

Beiträge zu diesem Thema: 2
Für Aktionen im ELV-Technik-Netzwerk müssen Sie sich ein Profil erstellen
Stromversorgungsproblem: RPI-RF-MOD mit Raspberry Pi 4 (Stacking Header) und SSD-Festplatte
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
26.07.2020, 16:12
Hallo zusammen,

ich verwende seit einiger Zeit erfolgreich einen Raspberry Pi 4 mit Stacking Header und dem RPI-RF-MOD.

Da ich einen etwas schnelleren Speicher wie die SD Karte verwenden wollte, habe ich alles auf eine SSD (externes Gehäuse USB 3 ) gepackt. Gebootet wird von SD und danach läuft alles (mehr oder weniger) über die SSD.

Nun zu meinem eigentlichen Problem. Seitdem die SSD angeschlossen ist und der Stromverbrauch deutlich gestiegen ist, funktioniert alles nur noch sehr sporadisch. Das Funkmodul antwortet leider nicht mehr regelmässig bzw. die Kommunikation ist immer wieder gestört. Meine aktuelle Vermutung ist der hohe Stromverbrauch in diesem Aufbau.

Bisher habe ich das empfohlene ELV Netzteil (2,5A) dafür verwendet und direkt am RPI-RF-MOD angeschlossen. Ohne SSD hat das bisher super funktioniert.

Alternativ habe ich ein hochwertiges 4A Netzteil verwendet, leider ebenfalls ohne Erfolg. Vermutlich ist der Strom den der raspi mit SSD zieht einfach viel zu hoch, da ich in der Doku etwas von max. 1100mAh fürs Funkmodul gelesen habe. Da bin ich sicherlich drüber.

Meine letzte Hoffnung/Idee war das orig. raspi 4 Netzteil mit 3A. Leider war aber auch das ohne Erfolg.

Verwendet vielleicht einer von euch einen ähnlichen Aufbau? Und wenn ja, welche Stromversorgung nutzt ihr?

Es wäre super wenn ihr mir einen Tipp geben könntet, ich bin so langsam etwas ratlos.

Vielen Dank und viele Grüße

Alexander
Aw: Stromversorgungsproblem: RPI-RF-MOD mit Raspberry Pi 4 (Stacking Header) und SSD-Festplatte
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
28.07.2020, 11:42
Ich weiß zwar nicht, ob es beim PI4 immer noch der Fall ist, aber bei den andern ist es so. Da ist zwischen der USB-Versorgung und dem eigentlichen Teil ein "Sicherungselement" (Polyfuse) das etwas Strombegrenzend wirkt und hier auch die Ursache sein könnte.

Alternativ dazu finden sich im Netz dann Vorschläge, den Pi direkt über die 5V GPIO-Pins zu versorgen, da dies "hinter" dem Sicherungselement ist (und daher als "gefährlich" eingestuft wird) - fällt dessen Effekt natürlich weg.

Wenn man dann noch ein ausreichend dickes Netzteil hat und an den USBs dann mehr Strom ziehen kann, als erlaubt, dann kann man damit ggf auch schon div. Leiterbahnen in Mitleidenschaft ziehen...

Evtl. wäre eine stromsparendere SSD oder ein M2.Sata Mudul mit USB-Interface eine Alternative. Plane ich shcon länger - komm nur nicht dazu :-)

(Ein Pi2-läuft seit Jahren mit einer "high endurance" SD-Karte 24/7/365" - wobei ich aber für permanent sich ändernde Daten aus eigener Applikation sowie das /var/log Verezichnis auf ein tmpfs verlegt habe.... das entlastet die Karte sehr...
Kein Backup - kein Mitleid!
Profil erstellen