Shop-Wechsel

Der Warenkorb wird nicht übernommen.

Zum Firmenkunden / Bildungseinrichtungs Shop

Funk-System Homematic

Schalten von 4 Kleingeräten

Liebe ELVforum-Community, mit dem heutigen Tag informieren wir Sie darüber, dass dieses Forum demnächst eingestellt wird. Alle weiteren Informationen zu diesem Schritt und welche Alternative wir planen, entnehmen Sie bitte dem angepinnten Forumsbeitrag.
Beiträge zu diesem Thema: 10

ELV Homematic Bausatz 4-Kanal-Funk-Schaltaktor für Batteriebetrieb HM-LC-Sw4-Ba-PCB

Artikel-Nr.: 130557

zum Produkt
Schalten von 4 Kleingeräten
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
05.01.2020, 15:10
Hallo,
ich möchte gerne mit Hilfe des HM-LC-Sw4-Ba-PCB folgendes realisieren: ich habe eine 5V/5A-Netzteil (Meanwell APV-35-5), an dem 4 Kleingeräte (Wemos, ESP mit max 1A/Gerät) hängen. Da die Geräte nicht leicht zu erreichen sind, möchte ich diese Geräte einzeln mal aus der Ferne aus-/einschalten können.

In der Beschreibung steht ja, das man 4x 20V/3A schalten kann.

Den Sw4 habe ich aufgebaut, angelernt und den Test aus dem Thread (https://de.elv.com/forum/keine-spannung-an-kl1-4-3317) mit 5V sowei einem 4,7kOhm Widerstand gemacht - funktioniert wie dort beschrieben.

Nur habe ich es nicht geschafft, aus nur einen Wemos so mit Spannung zu versorgen. Ich kann leider keine Zeichnungen anhängen, daher textuell:
- Netzteil/+ => 4,7kOhm => KL2/+ sowie Wemos/5V
- Netzteil/- => KL2/- sowie Wemos/GND
Ds entspricht m.M. nach der Zeichnung 2, Seite 8


Nun frage ich mich, ob ich da einer gedankliche Fehler aufgesessen bin, muss ich doch alle Geräte über Relais schalten? Ich hätte mir eigentlich ganz gerne eine weitere Platine gespart. Aber wenn es nicht anders geht .. kann ich zB ein 4-fach Relais-Modul nehmen?

Es tut mir leid, das ich da so wenig Ahnung von habe.

danke
Christian
Aw: Schalten von 4 Kleingeräten
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
05.01.2020, 18:22
Hallo christian,

unabhängig was Du machen möchtest...sehe Dir nocheinmal Bild 2/Seite 8 an. Dein Verbraucher/Last hängt einseitig an aber die GND-Seite der Last muss an die Klemme 1 gehen. Erst wenn der MOSFET durchgeschaltet hat, fließt ein Strom durch die Last.
Viele Grüße..elkotek
Aw: Schalten von 4 Kleingeräten
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
05.01.2020, 18:57
Ergänzung..habe gerade gesehen, dass einige Zeichen vom Editor nicht übernommen wurden. Der Editor nimmt keine Sonderzeichen an, deshalb die Hinweise in ()...

........unabhängig was Du machen möchtest...sehe Dir nocheinmal Bild 2/Seite 8 an. Dein Verbraucher/Last hängt einseitig an (+Ub) aber die GND-Seite der Last muss an die Klemme 1 (+) gehen. Erst wenn der MOSFET durchgeschaltet hat, fließt ein Strom durch die Last.
Viele Grüße..elkotek
Aw: Schalten von 4 Kleingeräten
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
06.01.2020, 10:05
Hallo Elkotek,

vielen Dank für Deine Antwort.


genau das setzt es bei mir aus.

Diese Zeichnung sagt für mich:
- KL5/- ist nicht verbunden
- KL5/+ ist mit +Ub (also dem Netzteil/+ verbunden)
- KL1/- ist mit GND verbunden - mit Netzteil/- ? und/oder auch GND vom Wemos?
- KL1/+ ist über den Pullup-Widerstand (ich habe 4,7k) mit +Ub (also Netzteil +) verbunden
wohin der Pfeil aus KL1/+ hinter dem Pullup geht ist mir nicht klar

Du schreibst aber, ich solle KL1/+ mit GND des Wemos verbinden?

Ich habe es mal versucht so aufzubauen, das der Pfeil an GND des Wemos geht -> da resettet der Sw4 sich immer.

Ich habe das Kleingerät gemessen, es verbrauch auch bei Start nicht mehr als 100-150 mA . Das ist eine kleine Schaltung, bei der ein Wemos mit einigen I2C-Modulen dran ist und zur Absicherung zwei Stützkondensatoren mit jew. 10000 uF.

Ich habe für den Pullup-Widerstand statt 4,7K auch mal 1M versucht, ohne Erfolg.

Vielen dank
Christian
Aw: Schalten von 4 Kleingeräten
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
06.01.2020, 10:34
Hallo christian,

mache einfach einmal folgenden Aufbau:

1. Nehme nur eine Betriebsspannung Ub = 5VDC (+), (- = GND)

2. Diese wird folgerichtig mit Klemme 5 verbunden

3. Als Last/Verbraucher nehme eine Signalanzeige..z.B. LED mit einem Vorwiederstand = ca. 1,5kOhm, Du kannst auch hier deinen 4,7 kOhm nehmen ---> Reihenschaltung aus beiden Komponenten

4. Die Anode (Anodenseite) der LED legts Du ebenfalls an die Ub (+)

5. Die Gegenseite an die Klemme KL1 (+)

6 Wird nun der Kanal 1angesteuert --> DrainSource Strecke wird leitend ---> und verbindet diesen Anschluß mit GND (-) ---> Strom kann fließen --> die LED leuchtet.

Dort wo nun der Vorwiderstand mit LED angeschlossen war...wird nun der gewünschte Verbraucher folgerichtig angeschlossen: Verbraucher: (+) Anschluß ---> Ub(+), (-) Anschluß ---> Klemme KL1 (+). Wenn hier Problem auftreten sollten, liegt dies an einer möglichen Einfluß des Verbrauchers ( hohe Last durch die 20000yF -- die zu einem kurzen Spannungseinbruch am Betriebsspannungseingang.

Funktioniert dies?
Viele Grüße..elkotek
Aw: Schalten von 4 Kleingeräten
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
06.01.2020, 12:57
Hello Elkotek,



ja, das funktioniert. Ich habe dann zusätzlich noch eine "nackten" Wemos an K2 gehängtm funktioniert auch, aber sobald die Kleinschaltung dran kommt, funktioniert es nicht mehr.

Dann ist das der "böse". Meine Messung des Verbrauchs ist nur die Anzaige am Labornetzteil und dann offensichtlich zu träge, um so kurze Spitzen zu erkennen (oder ich zu langsam um das zu lesen).

Ich nehme an, das läuft dann auf ein Relais hinaus?

Dann würde ich sinnvollerweise alle 4 Ausgänge so absichern, denn zwei der Geräte haben solche Elkos und dann bin ich auf Nummer sicher.

Wäre so ein 4-fach-Relasimodul eine Möglichkeit - die sind ja ziemlich kompakt und recht preiswert? Ich würde annehmen, das ich von dem Ralais-Modul VCC an UB+ und GND an UB- und IN1 an KL1+ anschliesse müssten. Oder bin ich da wieder falsch?

Ich hatte auch kurz an ein HM-LC-SW4-PCB gedacht, weil das Relais mit integriert sind, aber die machen nur 1A und wenn einer der Kleingeräte dann doch mal in Spitze mehr als 1A ziehen würde (zB die Kondensatoren), wäre das ja auch keine Option.

Danke
Christian
Aw: Schalten von 4 Kleingeräten
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
06.01.2020, 14:10
Hallo Christian,

die einfachste Möglichkeit wäre....

*..den HM-LC-Sw4-Ba-PCB beibehalten

*..zusätzlich an die jeweiligen Ausgänge ein Relais anschalten...Freilaufdiode nicht vergessen -->siehe hierzu Seite 8/Bild 1

*.. die notendige Spulenspannung der Relais richtet sich nach der Höhe der zur Verfügung stehenden Betriebsspannung....im einfachsten Fall kann dies die Betriebsspannung vom HM-LC-Sw4-Ba-PCB sein.

*..bei der Auswahl der Relais die notwendige/zulassige Kontaktbelastung beachten. Für die Last(en) mit der kapazitiven Belastung ein Relais mit einer Kontaktbelstung von 16A wählen, damit ein kleben der Kontakte vermieden wird

*..Beispiele für möglich Beschaltung der Ausgänge ist hier für den 1-Kanal HM-LC-Sw1-Ba-PCB dargestellt --->

https://www.magentacloud.de/lnk/N4sWiZ9u#file

Damit ein rückwirkugsfreier Betrieb des Schaltaktors gegeben ist, würde die Variante "C" wählen.
Viele Grüße..elkotek
Aw: Schalten von 4 Kleingeräten
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
06.01.2020, 16:15
Hallo Elkotek,

die Variante A unterscheidet sich von C darin, das auf der linken Seite KL1 (also K5 bei dem Sw4) noch eine weitere DIode (IN4001) zwischen Ub+ und KL2 (also KL1..4 bei dem Sw4) geschaltet ist und zusätzlich noch ein Kondensator (100uF) zwisched UB+ und UB-. Diese Diode und der Kondensator hat doch aber nix mit dem Relais zu tun (nur zu meinem Verständnis)?

Sind als Freilauf-Dioden (also "D1") auch IN4001 ausreichend? Es geht doch dabei um den Strom, den das Relais maximal braucht und nicht um die Stärke des geschalteten Verbrauchers? Sonst hätte ich noch ein paar BY251 zur Hand.

danke
christian
Aw: Schalten von 4 Kleingeräten
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
06.01.2020, 16:28
Hallo christian,

in der Variante "C" bedeutet die Diode D1 in Verbindung mit dem Elko, dass eine kurzfristige Belastung und/oder sonstiger Einfluß auf die Betriebsspannung zum Schaltaktor entkoppelt ist.

Als Freilaufdiode kan. man selbstverständlich eine 1N4148 ( bis ca. 100mA) oder auch eine 1N4001 ( bis 1A) verwenden. Wenn Du nur die BY251 hast, geht dies natürlich auch...da diese > 1A hat. Ich habe eben standardmäßig die 1N4007..hat nur eine höhere Sperrspannung.
Viele Grüße..elkotek
Aw: Schalten von 4 Kleingeräten
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
06.01.2020, 18:51
Hallo,

ich habe die Schaltung "C" nachgebaut, wobei ich als Dioden IN4007 genommen habe (Sowohl an K1 als auch parallel zum Relais. Das Relais ist ein Hongfa HF115F-H/005-1ZS3B (5V mit 220V/10A Schaltspannung/strom).

Die Betriebsspannung für das Relais habe ich so angeschlossen wie zuvor die Leuchtdiode (also Relais/- auf K1/+ und Relais/+ auf UB+.

Die Schaltspannung kommt von UB+ an den Verbraucher (Leuchtdiode/+), Leuchtdiode/- an Relais/COM und Relais/NO an UB-.

Es funktioniert mit der Leuchtdiode, es funktionierte aber nicht mit dem Kleingerät ;-((

Nun funktioniert es auch ohne Relais - des Rätsels Lösung (sehr blamabel): das Labornetzteil war auf max. 1A eingestellt. Die Kondensatoren haben wohl deutlich mehr gebraucht. Nachdem ich auf 2.5A erhöht hatte reichte es - im Leerlauf sind es nur 0.1A für Sw4 + Kleingerät.

Es tut mir leid, das ich dich da einem selbstgemachtem Phantom habe nachjagen lassen.

Vielen Dank für Deine Hilfe
Christian