Shop-Wechsel

Der Warenkorb wird nicht übernommen.

Zum Firmenkunden / Bildungseinrichtungs Shop

Funk-System Homematic

Kein Empfang bei direkter Spannungsversorgung

Beiträge zu diesem Thema: 5
Für Aktionen im ELV-Technik-Netzwerk müssen Sie sich ein Profil erstellen

ELV Homematic Bausatz 8-Kanal-Empfangsmodul HM-MOD-Re-8, für Smart Home / Hausautomation

Artikel-Nr.: 132143

zum Produkt
Kein Empfang bei direkter Spannungsversorgung
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
08.08.2017, 20:40
Hallo,

ich habe mein hier angedeutetes Problem näher untersucht.

Zunächst mal meine Schaltung:

Link zu Bild

Die vier ICs sollen das Homematic-Empfangsmodul darstellen, hatte leider keine bessere Entsprechung. Die Ausrichtung des Moduls ist am Anschluss 5v (rot) und GND (blau) zu erkennen. Tastereingänge werden mit grauen Kabeln versorgt, Ausgänge mit schwarzen Kabeln. Das andere Gerät ist ein Arduino Nano. Grundsätzlich soll die Schaltung später auf eine Platine gelötet werden und von innen meinen PC an- und ausschalten können.

Nun hatte ich ja im anderen Thread geschrieben, dass das Senden von Tasterbetätigungen vom Empfangsmodul an die CCU2 funktioniert; das Empfangen von Änderungen der Schaltzustände durch die CCU2, jedoch nur teilweise. Es hat sich herausgestellt, dass das senden funktioniert, wenn ich die 5V und GND über den USB-Port des Nanos beziehe (also USB-Kabel am Computer, das in den Mikro-USB-Eingang des Nanos geht). Wenn ich aber die 5V und GND direkt vom Mainboard (z.B. +5VSTBY) beziehe, funktioniert das senden reproduzierbar NICHT. Nun war mein Verdacht, dass der +5VSTBY vom Mainboard aus welchem Grund auch immer "zu schwach" ist und ich habe stattdessen die 5V und GND von den USB-Anschlussports des Mainboards genommen. Aber auch dort: Senden Fehlanzeige. Sowohl bei +5VSTBY als auch bei +5V des USB-Anschlussports am Mainboard messe ich gegen GND ~4,96V Potentialdifferenz.

Nun stellt sich mir die Frage ob ich den Strom, der direkt über das Mainboard bezogen wird, irgendwie "entstören" muss. Vielleicht macht der Arduino das ja, weshalb es über den USB-Port des Nanos funktioniert.

Kann mir dabei jemand helfen? Gehe ich da in die richtige Richtung? Oder hat jemand eine andere Idee?

PS: Falls jemand dazu noch eine Idee hat: Mit angeschlossenem Arduino Nano fährt der PC nicht gänzlich herunter. Nur vorher abziehen hilft. Jemand eine Idee?

Gruß
Matschbirne.

Aw: Kein Empfang bei direkter Spannungsversorgung
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
09.08.2017, 09:04
Mein Ansatz wäre, daß vom Mainboard die Spannung mit zuviel "Ripple" daherkommt, und so die Schaltung mit einer Schwingung vom Netzteil-Wandler Takt beaufschlagt, was zu Empfangsinterferenzen etc. führt.
Ich würde mal mit 1nF, 100nF und 100uF Elko - alles parallel - die Spannung entstören probieren, evtl. auch eine der klassischen Rundferritkerne, wie sie oft zu finden sind im PC zu entstören, also die Zuleitung vom Mainboard paar mal durchfädeln...
Kein Backup - kein Mitleid!
Aw: Kein Empfang bei direkter Spannungsversorgung
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
09.08.2017, 10:46
Hallo Rainmaker,

vielen Dank für deine Antwort. Das klingt für mich als Laie zunächst mal nachvollziehbar. Demnach würde der Arduino diese Entstörung mittels Elkos o.ä. machen, während das Homematicmodul den Störungen ausgesetzt ist, sobald der Strom direkt vom Mainboard bezogen wird.

Nun muss ich dazu sagen, dass ich, was die Elektronik angeht, absoluter Neuling bin und Schwierigkeiten habe deinen Lösungsansatz umzusetzen. Könntest du mir vielleicht ein Beispiel geben wo/wie genau ich Kondensatoren parallel dazwischen setzen soll? Das mit den Rundferritkernen muss ich zugeben habe ich nicht ganz verstanden.

Ich habe zuhause nur wenige Elkos (2x 100uF) und müsste gegebenenfalls nachbestellen. Gibt es da konkrete Empfehlungen für bestimmte Artikel oder kann man da was beliebiges nehmen?

Vielen Dank und Gruß
Matschbirne
Aw: Kein Empfang bei direkter Spannungsversorgung
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
10.08.2017, 09:14
Du kannst die div. Kondensatoren einzeln, gemeinsam alle in die Versorgungsleisten Deines Steckbrettes geben, also Mainboard IRGND und Mainboard IR+.
Nehmen kannst Du mal was an Kondensatoren da ist.
Elkos ist ein Versuch, aber Elkos können schlecht höhrere Frequenzen filtern, daher nimmt man da gern normale Kondensatoren dazu. Typ. sind 100nF, kannst aber probieren, was Du grad findest (oder aus einem andern defekten Gerät auslöten kannst).

Den Ferritkern in selbige Zuleitung zum Steckbrett...

Ich denke auch, daß der Arduino eine filternde Wirkung hat, weil ja seine eigenen Störungen (Prozessortakt etc.) wegkriegen muß.

Kein Backup - kein Mitleid!
Aw: Kein Empfang bei direkter Spannungsversorgung
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
10.08.2017, 13:15
Danke für den Tipp, das werde ich nachher ausprobieren! Mal sehen, was an Kondensatoren sonst noch so herumliegt 😉

Falls das nicht hilft hatte ich noch überlegt ggf. die Zuleitungen vom Mainboard an den USB-Port des Arduinos mit anzulöten. Nicht schön, sollte aber funktionieren. Mir wäre es - gerade des lerneffekts wegen - natürlich lieber es selbst zu lösen aber: Man kann nicht alles haben.

Danke und Gruß
Matschbirne
Profil erstellen