Shop-Wechsel

Der Warenkorb wird nicht übernommen.

Zum Firmenkunden / Bildungseinrichtungs Shop

Installationssender

Falscher Wert nach Reboot

Liebe ELVforum-Community, mit dem heutigen Tag informieren wir Sie darüber, dass dieses Forum demnächst eingestellt wird. Alle weiteren Informationen zu diesem Schritt und welche Alternative wir planen, entnehmen Sie bitte dem angepinnten Forumsbeitrag.
Beiträge zu diesem Thema: 13

Homematic 3-Kanal-Funk-Schließerkontakt-Interface HM-SCI-3-FM für Smart Home / Hausautomation

Artikel-Nr.: 092068

zum Produkt
Falscher Wert nach Reboot
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
16.12.2018, 17:26
Hallo,

ich habe einige dieser Schalter im Einsatz, und nach Reboot der Zentrale ist ständig der Wert falsch. Sie sind normalerweise bei mir offen, aber nach Reboot zeigen sie immer Zustand geschlossen, und ich muss dann immer manuell einmal zu allen hin laufen und den Kontakt kurzschließen und wieder öffnen, damit der Status in der Zentrale wieder korrekt ist.

Wieso kann sich die Zentrale den Zustand nicht über Reboots hinweg merken?

Danke
Maik
Aw: Falscher Wert nach Reboot
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
16.12.2018, 17:49
Hallo maikm,

dagegen läßt sich leider nichts machen. Was man lediglich realisieren kann ist, dass bei einem Zentralen-Neustart nicht eine ungewollte Programmtriggerung erfolgt...also bei "offenen" Fenster ein ungewolltes "geschlossen" erfolgt.

Gruß elkotek

Viele Grüße..elkotek
Aw: Falscher Wert nach Reboot
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
16.12.2018, 17:52
Könnte es sein, dass der Zustand erst nach einer Weile (wenn eine zyklische Abfrage erfolgt) korrigiert?
Christian
Aw: Falscher Wert nach Reboot
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
16.12.2018, 18:01
Das ist natürlich möglich bei den HmIP-Komponeten, denn hier kann mann die zyklische Statusmeldungen auf ca. 2,5 min einstellen, aber beim HM-SCI.. dauert dies ca. 24 Std.
Viele Grüße..elkotek
Aw: Falscher Wert nach Reboot
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
16.12.2018, 18:39
Ja, nur leider korrigiert sich der Zustand auch nach 24h nicht von selbst.
Aw: Falscher Wert nach Reboot
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
16.12.2018, 19:02
Hallo maikm,

sehe einmal im Gerätemenü nach...dort gibt es eine checkbox: zyklische Statusmeldung. Diese mußt Du aktivieren..Häkchen setzen.
Viele Grüße..elkotek
Aw: Falscher Wert nach Reboot
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
16.12.2018, 19:22
Ist gesetzt, und hatte ich auch immer gesetzt.
Aw: Falscher Wert nach Reboot
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
16.12.2018, 19:33
Aktueller HM-SCI/FW1.2
Hier wird nach ca. 24 Std. der Status vom Sender an die Zentrale übertragen/korregiert. Setze einmal die checkbox auf protokollieren und sehe Dir das Ergebnis dann im Systemprotokoll an.
Viele Grüße..elkotek
Aw: Falscher Wert nach Reboot
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
16.12.2018, 21:37
Werd ich mal beobachten. Trotzdem wäre auch das schon blöd genug: einer davon ist dazu da, Laufzeiten am Heizbrenner zu melden. Wenn der dann 6 Stunden lang Betrieb meldet, bevor der Kontakt tatsächlich wieder betätigt wird, ist meine Statistik schon im Eimer.

Warum kann sich die Zentrale das nicht merken? Das ist doch ein Bug? Und ich finde nicht mal über XML-API oder ähnliches eine Möglichkeit, den Wert nach Reboots wieder manuell zu setzen. Ich muss immer physikalisch hingehen und kurzschließen.
Aw: Falscher Wert nach Reboot
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
17.12.2018, 07:28
Ist es möglich
- Im Geräteseite der WebUI bei dem Gerät ein "Test" auszulösen, so das man sich wenigsten das latschen zum Gerät erspart?

- Nach dem reboot ein Programm (ohne Bedingung, mit Zeitverzögerung) auszulösen, welches ein 2-Zeiler-Script ausführt, dass STATE und VALUE abfragt, in der Hoffung die CCU holt sich dann den aktuellen Zustand




Christian
Aw: Falscher Wert nach Reboot
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
17.12.2018, 09:08
Geht leider nicht, da diese Art Low Power Geräte mit Knopfzellen nicht ständig auf Funkbefehle lauschen, sondern eben nur alle 24 Stunden einmal nachfragen oder wenn sie selbst gerade was gesendet haben.
Aw: Falscher Wert nach Reboot
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
17.12.2018, 09:52
Hallo maikm,

Du hast natürlich recht, dass der Vorschlag von Christian nicht geht. Das HM-System ist kein Pollingssystem und leider ist die Informationsübertragung eine Einbahnstraße ...die Statsuinformation wird immer vom Sender an die Zentrale übertragen.
Jede Art Abfrage..mit Value und/oder State greift deshalb immer nur auf den gecachten Wert in der Zentrale zurück..nicht auf den aktuell anstehenden Status am HM-SCI-3FM.

Eine fehlerhafte Bewertung einer Statusmeldung läßt sich natürlich per Programm vermeiden..so dass nur eine real durchgeführte Statusübertragung zu einer Programmtriggerung/Auswertung herangezogen wird.

Für die Realisierung gibt es mehrere Möglichkeiten....

*..generell arbeiten über eine eigene Systemvariable..deren Freigabe nur in Verbindung mit einer Reboot-Systemvariablen (falsch) arbeitet..also das setzen dieser Systemvariablen ist erst nach erfolgten Zeitablauf, z.B. erst 5 min nach einem Zentralen-Neustart wieder möglich ist
*..oder man nutzt eine script-Auswertung über ("$src$")..wo nur real durchgeführte Statusmeldungen zur Auswertung führen. Mit eieiner SysWerteliste könnte man damit eine differenzierte Auswertung realsieren.. --> unbekannt, offen, geschlossen..

Gruß elkotek
Viele Grüße..elkotek
Aw: Falscher Wert nach Reboot
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
19.12.2018, 14:02
Ich habe das Verfahren mit Systemvariablen schon für viele Szenarien im Einsatz, aber bei 98 Geräten alle Zustände da nochmal doppelt abzubilden ist mir echt zu blöd. Ich will auch in Apps wie pocketControl die realen Geräte handhaben und nicht nur Listen von on/off-Schaltern.

Ich würde es bevorzugen, wenn solche Bugs in der CCU gefixt werden. Das ist doch nicht zuviel verlangt?