Diverses

Display keine Funktion

Beiträge zu diesem Thema: 3
Für Aktionen im ELV-Technik-Netzwerk müssen Sie sich ein Profil erstellen

ELV I2C-BUS Displaymodul I2C-LCD, Komplettbausatz

Artikel-Nr.: 099253

zum Produkt
Display keine Funktion
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
13.11.2012, 11:41
Nach dem Aufbau der Platine (im Prinzip ja einfach; ein Hinweis auf den Quarz-Einbau vor der Displaymontage fehlt aber immer noch im Bausatz!) hat bei mir das Display mit den Beispiel-Programmmodulen für den Arduino leider keine Funktion! Eine Suche zu Forumsartikeln ergibt auf der Produktseite u.a. einen Hinweis auf drei Beiträge "USB-I2C-Interface und Displaymodul I2C-LCD von joe288 » 27.09.2011, 12:32 - 378 Zugriffe; aber der Link führt zum Fehler "-- 404 - file not found". Da ich das ELV-USB-I2C-Interface auch besitze: gibt es abseits der Programmierhinweise auch hierfür ein Testprogramm für die Funktion des I2C-Display-Moduls?

Am Arduino lassen sich die direkten Befehle zur Ansteuerung der LEDs usw. nutzen; nur das Display über die I2C-Ansteuerung zeigt keine Funktion. Beim Reset erscheinen kurz die linken, rechten und unteren Randsymbole; die eigentlichen Segmente im Zentrum bleiben unsichtbar.

Über Tips zum Fehler / zum Testen würde ich mich freuen!
Oder ist von einem Defekt auszugehen?

Viele Grüße
elvktr
Aw: Display keine Funktion
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
16.11.2012, 15:35
- da bin ich nochmal:
bisher hat ja keiner (auch nicht von ELV!) geantwortet - aber wenn man selbst nachforscht, kommt man ja in der Regel auch weiter ;-) :

- das Testprogramm für das I2C-Display am USB-I2C-Interface gibt es ja: ist eine Funktion (eigener Button) im "USB-I2C-Testtool" für das USB-I2C-Interface - hatte ich schlicht und einfach übersehen!

- am USB-I2C-Interface lassen sich damit die Display-Segmente auch ansteuern - somit ist das Modul OK!

- warum das Display am Arduino mit den zugehörigen Beispielprogrammen nicht läuft, ist jetzt noch zu erforschen - beim Kompilieren erscheint zumindest keine Fehlermeldung ...

Viele Grüße
elvktr
Aw: Display keine Funktion
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
30.04.2013, 17:45
- da bin ich nochmal in eigener Sache:
wieder hat keiner (auch nicht von ELV!) etwas kommentiert - schade!

Ich bin aber wieder selbst darauf gestoßen; daher ggf. für andere hier die Info: offenbar haben sich die Pinbelegungen des Arduino-Boards ab Rev R3 geändert und die SDA/SCL-Pins sind in Richtung USB-Port gewandert (bisher: Nutzung von A4 + A5). Es ist (mir) nicht ganz klar, bei welchem Board "alte" Sketches wie das zum ELV-I2C-Display ohne Änderung noch laufen: bei mir ging es mit dem Arduino Mega R3 halt nicht, aber mit einem nun verfügbaren Uno R3 ohne Probleme.

Viele Grüße
elvktr
Profil erstellen